Sujet en attente de réponse

Audio en DD 5.1 sur toutes les chaines Mycanal avec ATV 4K 2022

Yann240
Yann240
Niveau
1
271 / 750
points

J'ai acquis depuis peu une Apple TV 4K, la version 2022.
Elle est raccordée en HDMI e-ARC à mon TV qui lui est raccordé en optique à mon ampli HC (il ne supporte que le HDM 1.3 et donc pas compatible 4K et Atmos).
Je constate que depuis l'application MyCanal toutes les chaines TV envoient un signal Dolby Digital 5.1 à mon ampli (ce n'est pas le cas si j'utilise l'appli Mycanal de la TV).
Les chaines qui sont en 2.0 envoient un signal DD 5.1 mais seule les 2 enceintes avant envoient du son --> il s'agit donc de 2.0 encapsulé dans du DD 5.1
Si j'utilise d'autre applications comme Molotov ou ARTE sur l'ATV, j'ai bien du PCM 2.0 qui est envoyé à l'ampli.
La configuration audio de l'ATV est bien sur Auto, je n'ai pas forcé le DD 5.1. J'ai également activé de DD Atmos qui fonctionne bien avec Disney+ ou AppleTV+ lorsque j'utilise l'audio du TV (qui lui est compatible Atmos ;) )

Est-ce qu'il y en a d'autres qui ont constatés ce phénomène avec Mycanal sur une ATV 4K 2022 ?

Réponses de la communauté

sebnutt
sebnutt
Niveau
4
5000 / 5000
points

@essair

ceci est vrai pour un branchement comme tu le décris.

J'ai testé avec un montage ATV --> TV --> Ampli HC en SPDIF / Apple TV en audio Auto et c'est pareil : seul myCANAL sort du DD 5.1 sur des programmes 2.0 après avoir joué des contenus 5.1 natif. si on ferme myCANAL et qu'on le relance, en jouant du 2.0 l'ampli traite le PCM 2.0 activant ainsi le Prologic II.

essair44
essair44
Niveau
4
5000 / 5000
points

@Sebnutt
Je reviens sur nos histoires. Avec mon installation (ATV -> Ampli -> TV), j'ai fait les mêmes tests que toi avec Netflix et en mode Auto je n'ai aucun bug. Je reste bien en pcm 2.0 ou 5.1 selon le film . Le problème apparaît uniquement avec le mode DD 5.1 (que je n'utilise jamais d'ailleurs) ... De ce que je lis ici et sur le forum hcfr, le problème (avec l'ATV en mode Auto) semble ne concerner que ceux qui on une installation du type ATV -> TV -> earc-arc -> ampli ou barre de son.

essair44
essair44
Niveau
4
5000 / 5000
points

>Si l'on a du 2.0 à la base, on n'aura jamais un vrai 5.1 en sortie
Du vrai 5.1 non, mais un signal 2.0 a qu'en même des infos qui permettent avec un traitement DPL ou DPLII de base de sortir des effets corrects sur un ensemble 5.1.
C'est d'ailleurs le problème actuellement des programmes sportifs des chaines Canal, les infos 2.0 (ou 5.1) sont à la rue de sorte que sur une ShieldTV par exemple je n'ai des infos que sur la voie centrale ou que sur mon ATV (en mode Auto), je me retrouve avec le 5.1 de C+UHD d'un GP de Formule 1 en stéréo sur mes 2 colonnes avants.

sebnutt
sebnutt
Niveau
4
5000 / 5000
points

Evidemment, Gerarmanvuca :)

@sebnutt
Même si cela vous convient et qu'il y a eu énormément de progrès techniques dans le domaine des barres de son pour essayer de créer une bonne spatialisation par
un upmixer audio propriétaire, rien ne remplace un équipement HC digne de ce nom avec des enceintes physiques placées au bon endroit. ;-)

Cordialement

sebnutt
sebnutt
Niveau
4
5000 / 5000
points

@tndtnd "On ne peut pas faire de l'or avec du plomb !
Si l'on a du 2.0 à la base, on n'aura jamais un vrai 5.1 en sortie"

C'est vrai, et pourtant les équipements dernières générations proposent un upmix assez bluffant en terme de qualité.

sebnutt
sebnutt
Niveau
4
5000 / 5000
points

"Ce ne se produit que si on utilise la sortie SPDIF du TV, avec le HDMI ARC on a bien du PCM2.0"

sauf si on a visité une chaine DD / PCM 5.1 avant... dans ce cas, on hérite du 5.1 sur les chaines 2.0... :)

Yann240
Yann240
Niveau
1
271 / 750
points

Ce n'est pas du vrai 5.1, c'est juste du 2.0 encapsulé dans du DD5.1 avec 3 canaux inactifs.
Ce ne se produit que si on utilise la sortie SPDIF du TV, avec le HDMI ARC on a bien du PCM2.0

Bonjour à tous

@Yann240
"Les chaines qui sont en 2.0 envoient un signal DD 5.1 mais seules les 2 enceintes avant envoient du son --> il s'agit donc de 2.0 encapsulé dans du DD 5.1"

Dans ce cas, l'Apple TV ne fait pas de ré-encodage du DD 2.0 en DD 5.1 en temps réel (très compliqué à réaliser un "vrai" nouveau matriçage DD 5.1, à part en Studio de Mastering).

Cordialement

sebnutt
sebnutt
Niveau
4
5000 / 5000
points

Finalement, pour avoir du 5.1 sur toutes les chaines j'ai opté pour la stratégie suivante :

  • ouvrir les apps une à une
  • lancer un contenu 5.1 sur chacune d'elle
  • revenir à l'écran d'accueil
  • ne plus fermer les apps depuis le gestionnaire d'applications

J'éteins et rallume l'ATV et hop ! J'ai à nouveau accès à tous les contenus en DD 5.1 à chaque utilisation de l'Apple TV. Hormis YouTube, bien sûr.

PS : Je sais pas au bout de combien de temps le cache de l'Apple TV va se remettre à zero. Pour le moment, ça tient :)

sebnutt
sebnutt
Niveau
4
5000 / 5000
points

C'est pas gagné avec le support Apple....

sebnutt
sebnutt
Niveau
4
5000 / 5000
points

hello

pour info, même chose sur Prime Video :

  • Apple TV audio forcé sur DD 5.1
  • lancement d'un contenu 2.0 (Columbo) --> PCM stéréo
  • lancement d'un film en 5.1 --> DD 5.1
  • lancement à nouveau de Columbo --> DD 5.1

Exactement le même comportement, donc, que sur Netflix, myCANAL ou Disney+ (heureusement, les contenus en 2.0 y sont plus rares).

Pour YT, rien à faire, aucune conversion n'est jamais faite en DD 5.1, tout reste en PC 2.0...

J'ai contacté le support Apple au cas où ils accepteraient de traiter ça comme un bug...

sebnutt
sebnutt
Niveau
4
5000 / 5000
points

@Yann

je n'obtiens rien d'autre que du PCM stéréo sur YouTube, que ce soit en HDMI eARC ou en SPDIF, Apple TV en DD 5.1...

Yann240
Yann240
Niveau
1
271 / 750
points

@Sebnutt
Sur YouTube j'ai bien du 5.1
Milti CH In (5.1) en HDMI mais PCM 2.0 en SPDIF

sebnutt
sebnutt
Niveau
4
5000 / 5000
points

Je viens de faire le test ultime qui dédouane myCANAL : sur Netflix, j'ai commencé la lecture de Blade runner 2049 proposé en 5.1 --> PCM 5.1 (c'est normal). Si je lance ensuite Le Pleins Pouvoirs proposé en VF en 2.0 --> PCM 5.1 (on attendait du PCM 2.0).
A tester avec le Splitter HDMI E-ARC :)

CQFD

PS : Apple TV en Auto, TV en Auto (pas en passthrough)

essair44
essair44
Niveau
4
5000 / 5000
points

@sebnutt
Sur toutes les chaines 5.1 (C+UHD,C+cinema,OCS etc) c'est ok. C'est juste Eurosport (1 et 2) qui sort en 2.0 chez moi. Merci en tous les cas ...

sebnutt
sebnutt
Niveau
4
5000 / 5000
points

je n'ai pas Eurosport. Mais sur les chaines OCS, c'est le comportement attendu : 5.1...

essair44
essair44
Niveau
4
5000 / 5000
points

@sebnutt
Oui, en effet, dans ce cas cela ne vient pas de mycanal mais bien de l'ATV ...
Je rebondis sur mon problème des chaines Eurosport. Si tu les as, tu peux tester et me dire ce qui sort ? 5.1 ou 2.0 ? (ATV en mode Auto).
Merci

sebnutt
sebnutt
Niveau
4
5000 / 5000
points

Je viens de faire un test intéressant, qui pourrait incriminer l'Apple TV et pas myCANAL dans le bug décrit ici.

sur l'application Apple TV j'ai lancé un film qui propose la VF en AAC 2.0 uniquement --> PCM 2.0 sur la barre de son. J'ai ensuite lancé un film en 5.1 --> PCM 5.1 (je suis en Auto sur l'Apple TV donc tout sort en PCM, normal). Enfin je suis revenu sur le film 2.0 du début de séquence --> PCM 5.1 (et non plus 2.0).

Rien à voir donc avec myCANAL et pourtant même comportement. J'en déduis que c'est un bug de l'Apple TV.

essair44
essair44
Niveau
4
5000 / 5000
points

@sebnutt
Quand à mycanal, j'ai répondu sur le sujet que tu as crée, j'ai une autre anomalie avec Eurosport et ma ShieldTV.
Mycanal dit être en dd+ 5.1 et mon ampli m'indique du dd+ 2.0

essair44
essair44
Niveau
4
5000 / 5000
points

Ok merci ... Je comprends pas trop là ... Je vais tester avec ma config pour voir ...

sebnutt
sebnutt
Niveau
4
5000 / 5000
points

avec YouTube rien n'y fait, tout sort toujours en PCM 2.0, quelle que soit la configuration de l'Apple TV et du TV en amont... surement du au fait que YT ne propose que de l'AAC sur ses vidéos.

Preuve en est que l'Apple TV en mode DD 5.1 forcé ne réencode pas systématiquement le flux audio, en réalité, comme le ferait une Xbox Series, contrairement à ce qui est indiqué.

essair44
essair44
Niveau
4
5000 / 5000
points

@sebnutt
Ok là je comprends mieux ...
ça serait peut-être bien de tester avec Youtube si, comme avec mycanal et le mode DD 5.1 de l'ATV, le fait de passer une vidéo en 5.1 laisse le flux en dd 5.1 quand on repasse avec une vidéo 2.0.
@Yann240
Pour la sortie SPDIF, sans être sûr je pense aussi ...
Merci pour le test avec Eurosport.

Yann240
Yann240
Niveau
1
271 / 750
points

J'ai effectivement le problème sans le boîtier splitter et donc lorsque je suis en SPDIF.
J'ai l'impression que c'est le TV qui ré encodé en DD5.1 sur la sortie SPDIF

Yann240
Yann240
Niveau
1
271 / 750
points

Apple TV en auto

sebnutt
sebnutt
Niveau
4
5000 / 5000
points

"Si l'ATV est en mode Auto et ton TV en Auto c'est ok mais si l'ATV est Auto et ton TV en bitstream (passthrough) céki qui réencode en DD5.1 ?"

bon j'ai rien dit. test à l'instant : via HDMI eARC en Auto sur l'ATV et Bitstream ou Auto sur le TV, c'est PCM / LPCM partout.

sebnutt
sebnutt
Niveau
4
5000 / 5000
points

@yann Apple TV en Auto ou DD 5.1 forcé ?

essair44
essair44
Niveau
4
5000 / 5000
points

@sebnutt
Je n'ai pas le même comportement car mon ATV est branchée directement sur mon ampli ...
Donc pour toi (enfin je crois) c'est le même problème que Yann240 sans son extracteur HDMI.
Si l'ATV est en mode Auto et ton TV en Auto c'est ok mais si l'ATV est Auto et ton TV en bitstream (passthrough) céki qui réencode en DD5.1 ?